Unable to register default freeswitch extensions in soft phone

I am new to Freeswitch and installed Freeswitch on Debian, my FreeSwitch is up and running but when I try to register the default extension from the 1000.xml file and when I try to register in zoiper extension 1000 it is not registered. I do not know why?

In Zoiper I used 1000@ip and then 1234 as the password.

FreeSWITCH is not plug-and-play. It requires you to do some configuration work, such as changing the default password that you used. There will be other settings to change so I urge you to go ahead and edit the XML files without fear.

are good places to start.

The wiki is not perfect, but it can help you

Usual culprits are firewall or sip alg. Make sure the proper ports are open. Also, be sure to change the default password to something other than 1234.