Switch_core_file.c:346 Invalid file format [wav] - For all of the Music on Hold Files

I am learning all this by compiling and setting up.

I have not touched it in a month, done nothing with it at all. When I was involved with this last month, the was not appearing at all, then I boot the system up and I am getting flooding with that error.

Full error is :

2023-01-19 15:10:10.007389 98.43% [ERR] switch_core_file.c:346 Invalid file format [wav] for [/usr/local/freeswitch/sounds/music/8000/danza-espanola-op-37-h-142-xii-arabesca.wav]!
2023-01-19 15:10:10.007389 98.43% [ERR] mod_local_stream.c:361 Can’t open /usr/local/freeswitch/sounds/music/8000/danza-espanola-op-37-h-142-xii-arabesca.wav

Looking it up, I am not finding any solution for the cause of this.

Thanks!

mod_sndfile isn’t loaded.

Please verify that its in modules.conf.xml and that its loaded.

Thanks,
/b

Seeing mod_sndfile is in modules.conf.xml, I tried “load mod_sndfile” and an error was returned.

+OK Reloading XML
-ERR [module load file routine returned an error]

That error is not very helpful in what the problem is.

Thanks for responding

What distro and OS are you on? and was libsndfile-dev installed when you compiled?

It’s Debian 11 “Bullseye”
I see libsndfile1-dev is installed.

I guess I can try to compile and install again

Have you tried our packages? Something seems off compiling it, maybe you need to bootstrap again?

I am doing the source on purpose. As mentioned, this error did not appear when it was first compiled, and I really have not done any changes.

I tried again to compile and install and getting same error.

Have any packages for ARM?

apt-get update && apt-get install -yq gnupg2 wget lsb-release
wget -O - https://files.freeswitch.org/repo/deb/debian-release/fsstretch-archive-keyring.asc | apt-key add -
 
echo "deb http://files.freeswitch.org/repo/deb/debian-release/ `lsb_release -sc` main" > /etc/apt/sources.list.d/freeswitch.list
echo "deb-src http://files.freeswitch.org/repo/deb/debian-release/ `lsb_release -sc` main" >> /etc/apt/sources.list.d/freeswitch.list
apt-get update
apt-get build-dep freeswitch

Then try bootstrap and re-install from there.

On the ARM question, are you using RPi?

No, I am looking to install on Ampere after I get this figured out, but that will more likely be on their Ubuntu fork.