Remove Remote-Party-ID: "Outbound Call" Header

How to remove the Remote-Party-ID: “Outbound Call” header from the OK message being sent in response to a call getting answered, the “Outbound Call” is appearing on the phones and i would like to just show the caller number.

this is for direct user to user calls using the bridge command

<action application="bridge" data="user/${destination_number}@${domain_name}"/>

tried in the sip profile to set <param name="caller-id-type" value="none"/> but did nothing.
tried <action application="set" data="sip_cid_type=none"/> and did nothing.
also tried <action application="export" data="sip_cid_type=none"/> and did nothing.

appreciate any help!

Hello, Try setting caller-id-in-from to “true” in your gateway settings

caller-id-in-from (for those times the callerid is in the from for when the remote doesn't do rpid or p-asserted)

Hi, sorry i just noticed that the xml config i wrote was not shown as i didn’t format it properly.

I am not using a gateway, this is internal bridging between registered users.

ok so it works if i bridge without using user alias, so instead of doing this:
<action application="bridge" data="user/${destination_number}@${domain_name}"/>

i bridge through sofia:
<action application="bridge" data="sofia/internal/${destination_number}%${domain_name}" />

and in my sip profile i added this:
<param name="caller-id-type" value="none"/>

and now the Remote-Party-ID header is no longer added. for those who would like to user P-Asserted family header, i tested the same with : <param name="caller-id-type" value="pid"/> and the p-asserted-identity header was added to the outgoing invite

1 Like

Did you try : origination_caller_id_number / origination_caller_id_name ?